Solved [Rocket] Change Permissions

Discussion in 'Solved Questions' started by Mattalocity, Mar 27, 2015.

  1. Mattalocity

    Mattalocity N00b

    2
    1
    51
    How do I make it so others can use commands such as /kit because at the moment only admins can.

    this is my permissions:
    <?xml version="1.0" encoding="utf-8"?>
    <Permissions xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <ShowGroup>true</ShowGroup>
    <DefaultGroupName>default</DefaultGroupName>
    <AdminGroupDisplayName>Admin</AdminGroupDisplayName>
    <Format>[{0}] </Format>
    <WebPermissionsUrl />
    <WebPermissionsTimeout>60</WebPermissionsTimeout>
    <Groups>
    <Group>
    <Id>default</Id>
    <DisplayName>Guest</DisplayName>
    <Members />
    <Commands>
    <Command>p</Command>
    <Command>reward</Command>
    <Command>balance</Command>
    <Command>pay</Command>
    <Command>rocket</Command>
    <Command>kit</Command>
    </Commands>
    </Group>
    <Group>
    <Id>moderator</Id>
    <DisplayName>Moderator</DisplayName>
    <Members>
    <Member>76561197960287930</Member>
    </Members>
    <Commands>
    <Command>p</Command>
    <Command>p.reload</Command>
    <Command>tp</Command>
    <Command>tphere</Command>
    <Command>i</Command>
    <Command>test</Command>
    </Commands>
    </Group>
    </Groups>
    <WhitelistedGroups />
    <ReservedSlotsGroups />
    <ReservedSlots>0</ReservedSlots>
    <NotWhitelistedMessage>you are not whitelisted</NotWhitelistedMessage>
    <AllSlotsReservedMessage>all slots are in use</AllSlotsReservedMessage>
    </Permissions>
     
    Last edited: Mar 28, 2015
    sambranea likes this.
  2. Kilem

    Kilem N00b

    7
    0
    51
    set the groups up in permissions and then add members to groups that have the commands.
     
  3. Mattalocity

    Mattalocity N00b

    2
    1
    51
    I want it for anyone who joins. If a random person joins I want them to have the /kit permission
     
  4. Wuzzzel

    Wuzzzel N00b+

    26
    6
    58
    Your settings should be right. Everyone who joins is in the default group, wich has the permission for the command kit.
     
  5. sharkserver1

    sharkserver1 N00b

    1
    0
    1
    for kits u need to give them permission for the kit command then the kit, for expample i have a kit called guns, u need <Command>kit.guns</Command> in the group, i think u can also do <Command>kit.*</Command> for them to be able to use all kits with one permission, but i use kit.(kit name) and i know that works
     
  6. sambranea

    sambranea N00b

    2
    0
    1
    why do i only admins can Use the commands /kit /tpa and home my server can't be completed without that commands
     
  7. WaterBoyGaming

    WaterBoyGaming N00b

    3
    0
    1
    you need to add <Command>tpa.*</Command> to the default group

    or <Command>kit.kitname</Command> to the default group for the kits that you need
     
  8. sambranea

    sambranea N00b

    2
    0
    1
    can you give me your permission?
     
    Last edited: Apr 10, 2016
  9. WaterBoyGaming

    WaterBoyGaming N00b

    3
    0
    1
    *sigh* Alas no it has player data in it...but is a good place to start. Its how I learned xD
     
  10. apex2d

    apex2d N00b

    1
    0
    51
    Here's the default permission
    <Group>
    <Id>Default</Id>
    <Displayname>Civilian</Displayname>
    <Members />
    <Permissions>
    <Permission Cooldown="60">kit.(YOURKITNAME)</Permission>
    </Permissions>
    </Group>
     

Share This Page