1. Hello there, Guest
    It's nice to see you around, please do remember that our Forum was made by Members of the Community and that our Forum Applications are only for the Forum Moderation position. As this is an Unofficial Community we don't have control over Unturned Servers, Steam Accounts, VAC Bans, etc.

Tpa on my server

Discussion in 'Questions' started by Tie__, Dec 27, 2016.

  1. Tie__

    Tie__ N00b

    3
    0
    1
    Every time when someone trys to tpa in my server it says they dont have pressmission and I dont know how to fix this. Someone PLEASE help! (this is the config file)

    <?xml version="1.0" encoding="utf-8"?>
    <RocketPermissions xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <DefaultGroup>default</DefaultGroup>
    <Groups>
    <Group>
    <Id>VIP</Id>
    <DisplayName>Admin</DisplayName>
    <Prefix />
    <Suffix />
    <Color>#FFFFFF</Color>
    <Members />
    <Permissions>
    <Permission Cooldown="0">tpa.send</Permission>
    <Permission Cooldown="0">tpa.accept</Permission>
    <Permission Cooldown="200">/heal</Permission>
    <Permission Cooldown="20">/tpa</Permission>
    <Permission Cooldown="1">/god</Permission>
    </Permissions>
    </Group>
    <Group>
    <Id>Default</Id>
    <DisplayName>Guest</DisplayName>
    <Prefix />
    <Suffix />
    <Color>white</Color>
    <Members />
    <Permissions>
    <Permission Cooldown="0">tpa.send</Permission>
    <Permission Cooldown="0">tpa.accept</Permission>
    <Permission Cooldown="0">home</Permission>
    </Permissions>
    </Group>
    </Groups>
    </RocketPermissions>
     
  2. HazzaHEM

    HazzaHEM N00b

    5
    1
    3
    Hi, in my permissions file I usually just have tpa.*, not tpa.send or tpa.accept (In the Default player, section) so in your Permissions cooldown, it should look like this:

    <Permission Cooldown="0">tpa.*</Permission>
    <Permission Cooldown="0">tpa accept</Permission>
    <Permission Cooldown="0">home</Permission>

    Make sure you add the .* after the tpa, making it so the player can tpa to anyone.
    Hopefully this works.
     
  3. Sh4ggy

    Sh4ggy N00b++

    64
    5
    58
    This works yes, but be careful doing this as the * tells the config ANY or ALL things after "tpa." Be careful putting * anywhere in permissions as you can really severely break access to private commands.

    You may not want to do this in hindsight because you will not be able to configure individual cooldowns for TPA commands. A better option if you are still having trouble, is try installing a separate TPA plugin as there are several.
     

Share This Page